Issue in the Automation service
Incident Report for Cuseum
Resolved
Between Saturday (22/07) - Monday (24/07), we had a disruption in the Automation service. We are pleased to report that the issue has been resolved. We have confirmed that all systems are operating as expected. If you have any further questions or concerns, please don't hesitate to contact our support team. We apologize for any disruption this incident may have caused and thank you for your patience.
Posted Jul 24, 2023 - 16:00 UTC